PHP Laravel NGINX html css Bootstrap Python Symfony Apache Windows linux jquery Django ASP vanilla Slim vagrant docker Homestead MySQL Redis Git SVN ssh Root vim PhpStorm Pycharm sass less PHP Laravel android html css Vue Angular React NGINX html css Javascript

Ubuntu 18.04 LTS(Bionic)安装 Virtual Box

原创

原创不易 ~ 转载请注明出处哦

Ubuntu 18.04 LTS下,要安装Virtual Box,我们需要先从Virtual Box官网下载相应的.deb安装包:

https://download.virtualbox.org/virtualbox/5.2.16/virtualbox-5.2_5.2.16-123759~Ubuntu~bionic_amd64.deb

当前最新版本为5.2.16,如果有新版本,请在以下链接查看下载相应版本:

https://www.virtualbox.org/wiki/Linux_Downloads

Linux_Downloads – Oracle VM VirtualBox.png

但是双击安装时,我们发现安装不上。我们用命令行安装一下:

eagle@EagleEye:~/Downloads$ sudo dpkg -i virtualbox.deb

Selecting previously unselected package virtualbox-5.2.
(Reading database ... 187180 files and directories currently installed.)
Preparing to unpack virtualbox-5.2_5.2.16-123759_Ubuntu_bionic_amd64.deb ...
Unpacking virtualbox-5.2 (5.2.16-123759~Ubuntu~bionic) ...
dpkg: dependency problems prevent configuration of virtualbox-5.2:
 virtualbox-5.2 depends on libqt5opengl5 (>= 5.0.2); however:
  Package libqt5opengl5 is not installed.
 virtualbox-5.2 depends on libqt5printsupport5 (>= 5.0.2); however:
  Package libqt5printsupport5 is not installed.
 virtualbox-5.2 depends on libqt5x11extras5 (>= 5.6.0); however:
  Package libqt5x11extras5 is not installed.
 virtualbox-5.2 depends on libsdl1.2debian (>= 1.2.11); however:
  Package libsdl1.2debian is not installed.

dpkg: error processing package virtualbox-5.2 (--install):
 dependency problems - leaving unconfigured
Processing triggers for ureadahead (0.100.0-20) ...
Processing triggers for systemd (237-3ubuntu10.3) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu1) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.1) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for shared-mime-info (1.9-2) ...
Errors were encountered while processing:
 virtualbox-5.2

可以看到,原来是有dependencies没有安装。
手动安装一下:

eagle@EagleEye:~/Downloads$ sudo apt-get install libqt5opengl5 libqt5printsupport5 libqt5x11extras5 libsdl1.2debian

完成之后,再安装一次Virtual Box

eagle@EagleEye:~/Downloads$ sudo dpkg -i virtualbox.deb

(Reading database ... 188033 files and directories currently installed.)
Preparing to unpack virtualbox-5.2_5.2.16-123759_Ubuntu_bionic_amd64.deb ...
Unpacking virtualbox-5.2 (5.2.16-123759~Ubuntu~bionic) over (5.2.16-123759~Ubuntu~bionic) ...
Setting up virtualbox-5.2 (5.2.16-123759~Ubuntu~bionic) ...
addgroup: The group `vboxusers' already exists as a system group. Exiting.
Processing triggers for ureadahead (0.100.0-20) ...
Processing triggers for systemd (237-3ubuntu10.3) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu1) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.1) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for shared-mime-info (1.9-2) ...

这样Virtual Box的安装就完成了!


正在加载验证码......
请先完成验证